Error handling - Vipps
  • 05 Oct 2023
  • 2 Minutes to read
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Error handling - Vipps

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Article Summary

Here are some of the most common error messages you can get against Vipps

Below are solutions to the various error messages that may occur when processing an order that has been paid via Vipps.

Link to Vipps portalen

Vipps no order

When a customer pays with Vipps, the payment is first made. When the payment is confirmed, Vipps sends a message to the online store to inform that the payment has been made, and then the order is created.

If we do not receive a notification from Vipps that the payment has been made, no order will be created. Although this does not happen often, it can occur. In our systems, we see that we have not received any notification from Vipps. In such cases, the customer will never see the "order confirmation", nor will they receive an order confirmation email. Additionally, an order isn't created on your online store.

If you do nothing about this, the customer will get their money back after 8 days because the order is never marked as shipped.

We have created a tool in your control panel that allows you to activate or cancel such orders.

Read more about the tool.

In your Vipps portal, you can find the order ID that you need to activate or cancel your order. If you know which products the customer has purchased, you can activate the order and then create a manual order to have this recorded in your accounts.


Error Message: Client Error Response 404

[status code] 404
[Reason Phrase] Not Found
[url] https://api.vipps.no/Ecomm/v2/payments/T-1638377488-61a7a810ac2b0/capture

Cause

This error message is caused by communication failures on the API during the period that prevents payment from being activated on the order. Most likely, the payment is as reserved in the Vipps portal.

Solution

  1. Log in to the Vipps portal to see if the transaction has gone through.

  2. If the transaction has not gone through in the Vipps portal, you can try changing the status back to sent and reactivating the payment.

  3. If this is not successful, you can process the order despite error messages and then activate the transaction manually in the Vipps portal.

  4. If the transaction has gone through on the Vipps portal, the order can be processed despite error messages.

If you get the error message often, it can help with new API keys, for example. Check the article for guide on how to do this easily her.


Error Message: Client Error Response 499

We were unable to mark the order as shipped with Vipps. Error Message: Client Error Response
[status code] 499
[Reason Phrase]
[url] https://api.vipps.no/Ecomm/v2/payments/T-1695984355-6516aae3b87cd/capture


Cause

This error message is caused by communication failures on the API during the period that prevents payment from being activated on the order. Most likely, the payment is as reserved in the Vipps portal.

Solution

  1. Log in to the Vipps portal to see if the transaction has gone through.

  2. If the transaction has not gone through in the Vipps portal, you can try changing the status back to sent and reactivating the payment.

  3. If this is not successful, you can process the order despite error messages and then activate the transaction manually in the Vipps portal.

  4. If the transaction has gone through on the Vipps portal, the order can be processed despite error messages.



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